Как поменять зеркала на сервер Ubuntu от региональных до главной?

У меня есть четкий сервер (10.04), и я хочу поменять зеркало из США (или любой другой страны) на главное зеркало Убунту.

Например, мои первые две записи в источниках.список:

деб http://us.archive.ubuntu.com/ubuntu/ осознанные основной ограничен
деб-СРЦ http://us.archive.ubuntu.com/ubuntu/ осознанные основной ограничен

В окружении рабочего стола я хотел выбрать главное зеркало вроде этого:

Software Sources

Но как мне это сделать из терминала, так как не установлена графическая среда!

+450
Sumit Sil 12 сент. 2012 г., 22:59:19
24 ответов

Как пишет Аттила Фулоп, пакет в 13.04 сломан. Чтобы обойти эту проблему, введите

судо дополнения кв-репозиторий PPA:tortoisehg-НПА/релизы
судо apt-получить обновление
судо apt-получить обновление

Это будет скачать и установить версия работает нормально в 13.04. НТН

+920
Ladynewmoon 03 февр. '09 в 4:24

Мой файл-сервер в сети работает OpenSSH, в котором пользователи могут загружать и скачивать файлы с помощью SCP или помощью WinSCP. В то же время, сервер работает несколько веб-приложений (http), что нужен более высокий приоритет.

Есть ли способ, чтобы дать приоритет для HTTP через SSH передачи файлов? Если нет, Могу ли я ограничить пропускную способность СШ на входящие соединения?

+905
osdf 2 сент. 2017 г., 17:48:06

У меня эта проблема в Ubuntu 12.04 в VirtualBox установленную внутри Убунту 10.04. Мне помогло отключение IPv6 в 12.04, которое работает в среде VirtualBox (щелкните правой кнопкой мыши значок сети в правом верхнем углу >> изменить подключения >> Подключение имя [проводного подключения 1 в моем случае] >> откройте последнюю вкладку "протокол IPv6" настройки и выберите способ "игнорировать")

+899
DrRelling 28 дек. 2010 г., 23:58:56

Даже с опцией-V, пинг не делай этого. Вижу этот вопрос. Но если это действительно важно (или удовольствие), вы можете загрузить исходный код, изменить код, чтобы включить соответствующую функцию printf звонок. Хорошее место для того, что бы в конце метода 'send_probe' (линия 619 от 12.10)...

Сначала вы получаете источник

apt-получить iputils по источник 
компакт-диск iputils по*

Внести изменения

теперь пинг.с

Собрать и установить пакет, созданный...

apt-получить установку libsysfs-Дэв
с помощью dpkg-buildpackage используйте файл
+870
WJK 20 янв. 2013 г., 5:03:16

Для запуска Убунту/Линукс с внешнего жесткого диска, подключенного через USB процесс на самом деле довольно просто сделать. Вот несколько шагов, или, скорее, шаги, которые я взял.

Пожалуйста, обратите внимание: следующие шаги были проверены, используя версию Ubuntu 9.10, но не была протестирована с более поздних версий. Используйте на свой страх и риск и усмотрение.

Что Вам Понадобится

  1. Компьютер с доступом в интернет.
  2. LiveCD или LiveUSB в с Ubuntu.
  3. Внешний жесткий диск с возможность USB.

Что Делать

  1. Откройте ваш компьютер и извлеките жесткий диск.
  2. Подключите внешний жесткий диск USB через кабель USB.
  3. Придерживаться в вашей помощью LiveUSB или LiveCD и затем загрузиться ваш компьютер.
  4. Открыть меню загрузки и выбрать загрузку с диска LiveCD/LiveUSB в.
  5. Во время процесса установки вы должны указанный внешний жесткий диск, установить Ubuntu на что.
  6. Завершите процесс установки, выключите компьютер, и поставить другой жесткий диск на вашем компьютере.
  7. Перезагрузите компьютер, зайдите в меню загрузки и выберите внешний жесткий диск и попытаться загрузиться с него. Если это так Поздравляю, теперь у вас есть внешний жесткий диск с полноценной операционной системой на нем.
  8. Заказать внешний жесткий диск с Ubuntu/Линукс! Пожалуйста, дайте мне знать, если это помогает вам! Если не дайте мне знать об этом. :)
+780
Mag 1 янв. 2016 г., 23:55:16

Вы упомянули, что вы используете в tcsh. Семья с-снаряды не совместима с Борном снарядов. Эта команда может работать:

набор THREE_FILES=`поиск ...`
СР $THREE_FILES NEW_DIRECTORY

Первый набор команд делает новая переменная окружения называется THREE_FILES и сохраняет выходные данные в эту переменную. В СР занимает три файла и копирует их в NEW_DIRECTORY.

+707
Mushkitoes 21 июл. 2018 г., 3:33:20

Во-первых, аудио-используется для воспроизведения из динамика, но когда я подключил наушники или динамик в Я, звук не пришел. Так что я установил звуковой драйвер Realtek, чтобы это исправить (на самом деле я не нашел никаких соответствующих драйвер для моей звуковой карты, так что я установил его в надежде, что он покажет какой-то свет)

Когда я перезагрузил систему, звук полностью исчез и теперь Ubuntu не обнаруживают каких-либо звуковых устройств в системе. Я четко установлен неправильный драйвер, теперь мне нужно удалить и перейти на предыдущий этап и найти правильные драйвера.

Я скачал последний пакет от компании Realtek сайт, извлечены tar.gz файл и запускал установочный файл внутри каталога, извлеченные из терминала с помощью команды судо ./установите

Мой ноутбук: Dell Студио 1747, использует акустическая система Creative Labs звук Х-Fi Мб Звуковая бластер и набор микросхем от Intel PM55.

Как я могу это исправить?

+705
Chris Horsley 20 дек. 2016 г., 12:45:40
winbindd — служба имен переключателя daemon для разрешения имен серверов НТ
+671
rax0m 16 дек. 2015 г., 13:28:48

Вы можете только быть пропущены фактический метод шифрования, который, кажется, должен быть указан в

[Сервер и протокол PPTP 2.8]

и

[Сервер и протокол PPTP 2.8 тоннеля]

блоки из вашего примера. Это должно примерно перевести на современное окно, в Нм-апплет конфигурации VPN по протоколу PPTP:

PPTP Advanced Options

Я предлагаю сначала пытается включить шифрование MPPE и сохраняя все остальные параметры по умолчанию (так, что оно включено шифрование MPPE, которое предлагает шифрование, и mschap-тип методов проверки подлинности, которые включены в ваш пример для протокола PPTP раздел 2.8). Если это не сработает, попробуйте отключить все параметры проверки подлинности, но ППА, так что все будут равняться примерно такая же, как в разделе "протоколы PPTP 2.8 тоннель" в вашем примере.

Если это любое использование, там сейчас баг на Launchpad открыто о поддержке импорта в CMS-тип настройки в менеджере сетей: ошибка 711282

+603
yco 2 июн. 2018 г., 19:18:47

Это легко. Я буду ссылаться на другого моего ответа и дать смысл для вашего случая. Другие мои ответ был: когда Убунту просит администратора пароль пользователя, как это решить, что пользователь с правами администратора, чтобы спросить?

Суть заключается в редактировании файла/etc/пользователям использовать sudo? и добавить Cmnd_Alias (скажем PRIVCMDS) за команду, которую вы хотите разрешить, а потом что-то подобное В пользователям использовать sudo?:

%Убунту все=(корень) NOPASSWD:PRIVCMDS

Но, пожалуйста, прочитайте мой полный ответ на другой вопрос.

Выше для системы группу под названием Убунту. Если вы хотели того же, для пользователя с именем Убунту было бы прочитать:

в Ubuntu все=(корень) NOPASSWD:PRIVCMDS
+534
DarthPaghius 27 мая 2014 г., 9:37:42

После обновления до Ubuntu 11.10 принтер - НР принтеров DeskJet F300 по серии - больше не печатать из любого текстового процессора, в том числе редакторе gedit. Сканер все еще функционирует, и я могу распечатать письма. Это было правильно работать с TextMaker, LibreOffice и теперь перед обновлением

+489
menfix 29 апр. 2013 г., 16:56:33

Если вы установили Ubuntu от Windows с помощью wubi , то просто запустите файл Uninstall.

+465
Ajimac0 8 нояб. 2010 г., 11:43:09

Пару (я считаю) взаимосвязанных вопросов, касающихся индикатор обмена сообщениями:

  1. Почему индикатор сообщений в Ubuntu апплет индикации 3 экземпляров почтовый ящик ?
  2. Почему новые сообщения не появляются в папке "входящие" ссылки?
  3. Мне было бы любопытно знать, почему новые сообщения не горит значке панели.

Это не проблема с будучи в состоянии открыть и прочитать новые сообщения в эволюции. Кроме того, всплывающие подсказки указывают на то, что прибыла новая почта. Само по себе выше указанные аномалии являются чем-то я могу терпеть. Однако, это все работало до обновления до 11.04 с 10.10.

+421
Leslie Boyd 30 сент. 2018 г., 21:32:10

Я хочу использовать мой собственный просмотрщик документов (программа) и никогда не хочу снова увидеть выказывают.

В Ubuntu 13.04, когда я пытаюсь обновить -П выказывают, он говорит, что Ubuntu-Desktop зависит от него.

+332
Brock Fansler 15 нояб. 2017 г., 21:02:25

Вы можете удалить Тандерберд:

  1. открыть терминал: сочетание клавиш Ctrl+АЛТ+Т
  2. Выполните следующую команду:суда apt-получить удалить --продувка Тандерберд -г
  3. Выход терминал: выход
+277
MBosman 16 сент. 2019 г., 10:57:59

Согласно поддерживаемого оборудования таблица видеокарт ATI драйвера вы должны использовать уже установлено и используется по умолчанию в Ubuntu 11.10.

Вашей карты, на ATI x1150 с использует чипсет RS400, которые, согласно таблице, поддерживается катализатора наследство или драйверы с открытым исходным кодом.

Поскольку первое не может быть установлена в Ubuntu 11.10 если вы не в состоянии установить и использовать версию 2.6.28 ядра (или ранее) вы сможете использовать второй и которая уже установлена в вашей системе.

+253
AMINU 15 мая 2013 г., 3:01:58

У меня была проблема с Ubuntu 10.04 и 10.10 перегрева и используя все мои процессор и большую часть моей памяти. Я просмотрела эти форумы, но не вижу ничего, что подходило под описание моей проблемы, поэтому я просто начал возиться. Я заметил в системном мониторе, что xorg делает большинство повреждений. Я сделал остановки процесса и, что взаперти мой компьютер, потому что для xorg управляет оконной системы. В любом случае, сделал перезагрузку и мой компьютер не запускался чрезмерно горячей, так и ЦП, где она должна быть. Надеюсь, что это полезно, а не просто везение с моей стороны.

+200
Dency G B 2 окт. 2013 г., 5:03:04

У меня недавно был Windows XP и умереть на одной из моих машин, и установили Ubuntu. ОС работает отлично, за исключением установки принтера Xerox принтер Phaser 3160N.

ОС может найти и установить сетевой принтер, но при печати тестовой страницы, он говорит мне

Внутренняя ошибка: пожалуйста, используйте правильный драйвер.

У меня есть правильные драйверы, как ваша поддержка команды прислал мне ссылку, но я не могу установить эти драйверы для запуска принтера.

Эти инструкции-лайн руководство по установке на Linux-машине:

  1. Убедитесь, что устройство подключено к сети и работает далее. Кроме того, IP-адрес вашего компьютера должен быть назначен.
  2. Вставьте прилагаемый компакт-диск в дисковод для компакт-дисков.
  3. Дважды щелкните значок компакт-диска значок, который появляется на рабочем столе в Linux.
  4. Дважды щелкните папку в Linux.
  5. Дважды щелкните значок install.sh .
  6. Окно установки принтера Xerox открывает. Нажмите Кнопку "Продолжить".
  7. Окно Мастера установки принтера открывает. Нажмите Кнопку Далее.
  8. Выберите сетевой принтер и нажмите кнопку "Поиск".
  9. IP-адрес принтера и название модели появится в поле списка.
  10. Выберите свое устройство и нажмите кнопку Далее.

Я понимаю, насколько Шаг 5 и Шаг 6 не бывает, если это случилось, это было бы очень легко оттуда.

Есть варианты, чтобы добавить дополнительного программного обеспечения в Ubuntu, однако она не распознает установочный диск как силу, когда я пытаюсь добавить его в качестве источника.

Любые идеи, как это исправить?

+196
Jersey Guy 1 июл. 2017 г., 19:08:07

У меня есть проблема. Я только что обновил до 11.10 и принтер перестал работать с отчетностью функцию error_log:

Принтер не может взаимодействовать с компьютером.

Из исследования я сделал, люди говорят, что на Windows неправильного драйвера может быть причиной. Водитель, которая доступна от компании Lexmark, который я имел для осознанных и Maverick, видимо, не поддерживается на Онейроидного. Что интересно, что система распознает принтер присутствует и модель, а также любых устройств, подключенных к кард-ридер.

Кто-нибудь уже смог драйвер Lexmark работать?

П. С. Этот вопрос может быть тесно связанных, но просит другую вещь.

П. П. С. Я просто подтвердил, что он работает с Нэтти, а также.

+171
James Nery 4 дек. 2013 г., 4:37:25

У меня вчера такая же ошибка. Я попытался установить каждый пакет Emacs в репозитории, и когда это не сработало, мне пришло в голову, что, возможно, конфликты были проблемы. Поскольку я не нуждался в emacs23 если в Emacs-моментальный снимок будет работать, я сделал следующее:

Удалить Все Пакеты Для Emacs

Прежде чем продолжить, взгляните на то, что пакеты для Emacs может быть установлен путем выдачи `судо АПТ-кэша поиска в Emacs'. Если вы можете пожертвовать всем в выходной, идти вперед с таким предложением.

суда apt-получить удалить `АПТ-кэша поиска в Emacs | у awk '{печати $1}" --продувка

Если что-то еще появляется в выходных данных, которые вы хотите сохранить, быстрый способ избавиться от вещей, которые вы не хотите, чтобы перенаправить вывод команды в файл, отредактировать, и затем использовать содержимое этого файла для того, чтобы аргументированно apt-получить удалить.

  1. судо АПТ-кэша поиска в Emacs > remove.txt
  2. Редактировать remove.txt путем удаления строк из пакетов , которые вы хотите сохранить. Цель здесь состоит, чтобы избавиться от всего, что вообще связано, так что оставьте эти пакеты в файл.
  3. судо кот remove.txt | команды xargs apt-получить удалить --продувка

Вы можете получить здесь некоторые ошибки с помощью Emacs-снимок не удалось правильно установить. Если вы это сделаете, попробуйте удалить эти пакеты вручную заставить установить сломанные пакеты и затем удалить-их очистку.

суда apt-получить -Ф установка # не список пакетов здесь
судо apt-получить удалить в Emacs-снимком-продувки

Это, наверное, тоже хорошая идея автоочистка и autoremove.

судо apt-получить автоочистка
судо apt-получить autoremove

Установить В Emacs 24

суда apt-получить установку для Emacs-снимок

Это предполагает, что вы ППА правильно добавил (Я использую кассу ППА также). Все, кажется, хорошо работать сейчас!

Попробовать профпригодность

Поскольку изначально писать этот ответ, я перешел на использование способностей , чтобы управлять пакетами в командной строке. Мне не нравится графический интерфейс (на ncurses) вы получаете от выдачи судо способность, так что я только использовать его, когда мне нужно решить зависимостей/конфликтов, оставшиеся от экспериментов с различными окружениями рабочего стола. Большую часть времени я просто использовать его как падени-в замене для apt-получить, как в судо способность установить [пакет].

По теме: является aptitude еще выше apt-получить?

+122
mrb101 19 дек. 2016 г., 6:41:30

Какие панели задач/панели доступны в Ubuntu ?

Что нужно делать, чтобы настроить их ?

+83
Rohit Funde 6 июл. 2012 г., 2:03:16

У меня есть старенькая машина, и единственный способ я могу установить Ubuntu заключается в использовании Wubi, но я получаю сообщение об ошибке.

Вот лог: http://pastebin.com/a5YjaaKv

01-11 23:09 CommonBackend ошибка: неверный MD5 для ИСО C:\ubuntu\install\installation.iso (5d5d1a7da2a0659b163d4f8bd70fbe6f != 99594c45a0175a5570cdcc5c9cb3ed8f)
Нет
01-11 23:09 отладки задач: ### закончил check_iso
01-11 23:09 отладки задач: ## готовые use_cd
01-11 23:09 отладки задач: ## под управлением extract_kernel...
01-11 23:09 список задач ошибка: не удалось загрузить требуемые файлы установки 
Обратная трассировка (самый недавний призыв последнего):
 Файл "\lib\wubi\backends\common\tasklist.py" линия 197, в __звоните__
 Файл "\lib\wubi\backends\common\backend.py" линия 618, в extract_kernel
Исключение: не удалось загрузить требуемые файлы установки 
+52
llyando 16 мар. 2019 г., 7:25:14

Возможные Дубликаты:
Менеджер загрузок для Ubuntu

Что является лучшим графическим менеджером скачивание?
Мне нужно что-то, что выглядит как IDM для Windows

+49
John Francis Murphy 5 сент. 2012 г., 14:32:25

У меня был документ, который был синхронизирован по Ubuntu один. Я вчера редактировал его, но когда я его открыла сегодня месяц старая версия.

Что я могу сделать, чтобы восстановить мою работу?

+32
Loraine 25 дек. 2011 г., 21:16:27

Показать вопросы с тегом